Flash Install Notes

Adobe This site requires the Adobe Flash Player version 9,0,45,0 or later.
You can check your version here
And you can install the latest version from here
Note: Flash has separate installs for Internet Explorer and Firefox / Mozilla / Netscape / Opera / Safari.

IE Note for Internet Explorer :
If you receive the message "Unable to authenticate installer"
Please try the following instructions :
In Internet Explorer, select Tools > Internet Options > Programs > Manage Add-ons and select Shockwave Flash Object and then click "Update ActiveX"
After this you should recheck the version.